Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2011
    Location
    Pender,Ne
    My Ride
    2006 212 Interceptor
    Posts
    53
    Post Thanks / Like

    5.0 Mercruiser engine alarm

    Took the 212 Interceptor for a ride last Saturday. 3000 rpm we got an intermittent double beep ever 3 to 4 minutes. Stopped and floated half hour and did not occur again until I headed for home at 4200 rpm we got a constant beep after traveling 20 minutes. Gearlube is good, as are all fluid levels, gauges all read where they are normally, oil pressure in the low 40's, temp was 10 degrees warmer at about 165, good voltage. With the river water temp being 80 degrees is it causing a water temp sensor to go off? Once again it's a 5.0 L Mercruiser with a Bravo I. Thanks for any advice!

  2. #2
    Join Date
    Feb 2013
    Location
    close to GG bridge
    My Ride
    2006 Formula 280 bowrider
    Age
    49
    Posts
    89
    Post Thanks / Like
    Had a very similar issue awhile back. Wes from Proboat determined that it was the IAC ( idle air control) failing.
    It failed and the boat wouldn't idle.
    My 5.0 merc had the same symptoms:
    intermittent beep every few minutes

  3. #3
    Join Date
    Dec 2003
    Location
    Papillion, NE
    My Ride
    32 Active Thunder
    Age
    53
    Posts
    6,686
    Post Thanks / Like
    Probably IAC going bad, but get it scanned to verify.

  4. #4
    Join Date
    Jan 2011
    Location
    Pender,Ne
    My Ride
    2006 212 Interceptor
    Posts
    53
    Post Thanks / Like
    I do believe you guys are correct in your assessments. After starting the boat I do recall the idle fluctuating one time before we took off. I think I will try the IAC first. Hate to do it that way but I would have to pull the boat 50 miles to get it scanned, and I am capable enough mechanically to switch the IAC. Thanks for the help!!!

  5. #5
    Join Date
    Jan 2011
    Location
    Pender,Ne
    My Ride
    2006 212 Interceptor
    Posts
    53
    Post Thanks / Like
    Thanks, Formula 28 and Griff, Installed new IAC and filter and boat ran like a champ. Went from Pop n Docs to Rivertime for a beautiful Sunday afternoon run!

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
MWBP Sponsors









Yellow Pages